Instalar LibreOffice en LMDE desde PPA


¿Cansado de instalar LibreOffice mediante dpkg? Desde ayer si no me equivoco, está disponible un PPA en Launchpad con Libreoffice, el cual, podemos utilizar en Debian o LMDE para instalar y mantener actualizado este paquete ofimático.

Personalmente siempre hago un mirror local de cuanto repo o PPA use, no obstante les mostraré como instalarnos LibreOffice desde Launchpad. Este PPA es para Ubuntu, pero no importa, porque funciona perfectamente en LMDE.

Lo primero es añadir a nuestro source.list la siguiente línea:

deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu lucid main

Luego actualizamos:

$ sudo aptitude update.

Eliminamos cuanto paquete de OpenOffice existe en nuestro ordenador. Esto si lo prefieren lo hacen mediante Synaptic.

$ sudo aptitude purge openoffice.org-base openoffice.org-base-core openoffice.org-calc openoffice.org-common openoffice.org-core openoffice.org-draw openoffice.org-emailmerge openoffice.org-gnome openoffice.org-gtk openoffice.org-help-es openoffice.org-impress openoffice.org-java-common openoffice.org-l10n-es openoffice.org-math openoffice.org-style-tango openoffice.org-writer

Y posteriormente instalamos los paquetes que necesitemos de LibreOffice.

$ sudo aptitude install libreoffice-base-core libreoffice-draw libreoffice-emailmerge libreoffice-filter-binfilter libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-java-common libreoffice-l10n-common libreoffice-l10n-es libreoffice-math libreoffice-style-oxygen libreoffice-style-tango libreoffice-writer

Listo!!

 

Splash de LibreOffice
LibreOffice Writer

 

7 comentarios en “Instalar LibreOffice en LMDE desde PPA

  1. Perdon, no hablo espanol, pero…

    Thanks for the tip! Worked great.

    However, I couldn’t load spell-check to LibreOffice in any language, even after doing:

    sudo aptitude install libreoffice-l10n-es
    sudo aptitude install libreoffice-l10n-en-us
    sudo aptitude install libreoffice-l10n-it
    sudo aptitude install libreoffice-l10n-de

    Any ideas on what went wrong?

    Ud. puede contestar en espanol. No see escribier, ma lo puedo compreender.

  2. Sorry for the dumb question, I am answering myself here.

    Those files are only interface package languages. Not dictionaries. For dictionaries, for the moment, it seems that it is necessary to do it the old OOO way, downloading extensions here:

    http://extensions.services.openoffice.org/en/dictionaries

    The link on LibreOffice’s Tools -> Language -> More Dictionaries On-line currently leads to a page with very limited extensions (apparently, those certified as “non-proprietary”).

    Sorry again for the dumb question and for invading your page in Spanish.

    Thanks again for the tips.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s